Welcome, Guest
Please Login or Register.    Lost Password?

Problem with &-Character? (35) 0 Wrong when..
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Problem with &-Character? (35) 0 Wrong when..
#18566
Problem with &-Character? (35) 0 Wrong when.. 1 Year, 8 Months ago  
Hi,
I just bought the Pro-Version an now wanted to add the Calendar from my university via iCal.

I just got a URL like this:
Code:

https://online.uni.at/ws/calendar/ical?pStud=ASFASFA0&pToken=AAGERAGASDF

(of course this one is only an shortened / changed example, I made up for demonstration...)
I added it as Network Shared Calender.

Now I always get the following error-message:
Code:

Error downloading the data from url:
https://online.uni.at/ws/calendar/ical?pStud=ASFASFA0pToken=AAGERAGASDF

Server returned result: (35) 0 Wrong when
connecting with SSL.



The strange thing about the error message is: The original url contains the character &
In the error message this character is missing.

The url itself seems to be perfectly fine. My google-calender has accepted it without any complaints and pasting the url into a Browser I can download a .ics file that seems to be just fine.
Netman
Fresh Boarder
Posts: 4
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#18579
Re: Problem with &-Character? (35) 0 Wrong when.. 1 Year, 8 Months ago  
The error 35 means that Rainlendar is not able to create a secure connection to the server. The problem happes before the rest of the url is used so the '&' char in the url most likely is not what is causing the problem. The SSL related errors usually are caused by firewalls, incorrect certificates, proxy servers and such. Are you able to read the calendar with normal http protocol (i.e. without the 's' in https)?
Rainy
Moderator
Posts: 5971
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#18585
Re:Problem with &-Character? (35) 0 Wrong when.. 1 Year, 8 Months ago  
Well, it's a link generated by the online-system of my university. As a student I am not able to modify it. With http a normal browser always redirects to https and Rainlendar says: "(35) 302 Wrong when connecting with SSL".
But - as it is a university with some it-professionals - I assume they have configured certificates ect. correctly and the error happens on my side.
Furthermore if there would be something wrong with the url, Intenet Explorer and gmail should have returned an error.


I use no proxy servers and for testing I just switched off Windows Firewall and Antivir. Nothing changed, the error is still persistent.

I am on Windows 7 Professional 64-Bit and use Rainlendar 2.11 (b128) 64 bit.
Netman
Fresh Boarder
Posts: 4
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#18594
Re:Problem with &-Character? (35) 0 Wrong when.. 1 Year, 8 Months ago  
If you think that maybe the '&' character is causing this problem, you can try :
use '%26' to replace '&' character.
anoob
Platinum Boarder
Posts: 502
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: TaiChung, Taiwan, R.O.C. Birthday: 02/12
The administrator has disabled public write access.
I couldn't speak English! This skin released to Customize.org(Do you want it? Click Picture) Please contact me if interested: jhg5702@gmail.com
 
Go to topPage: 1
get the latest posts directly to your desktop