Welcome, Guest
Please Login or Register.    Lost Password?

all settings lost; missing "license.r2lic&quo
(1 viewing) (1) Guest
Go to bottomPage: 1234
TOPIC: all settings lost; missing "license.r2lic&quo
#1636
Re:all settings lost; missing "license.r2lic& 7 Years, 9 Months ago  
The log gets overwritten every time Rainlendar is started so it doesn't show anything. This could happen if the the power is cut while the configs are being written but that shouldn't happen too often. The settings file is handled by the wxWidgets framework so I'm not exactly sure how thing work or if there is anything I can do about it.

Is this a common problem? Are there any other users who have experienced this?
Rainy
Moderator
Posts: 5991
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1641
Re:all settings lost; missing "license.r2lic& 7 Years, 9 Months ago  
As a temporary workaround, you might consider having RL create a backup of this file every other day or so.

Speaking of which though, some basic backup functionality would be really nice - and simple too: Once a day create a new timestamped folder in the backups dir (e.g. .../Rainlendar/backups/2007-01-07_1824/) and copy the settings and calendar files there. If there are more than 10 folders, the oldest ones should be deleted. (Of course the backup interval and number of folders to retain might also be customizable, but that's not really needed for the most part.)
This would certainly give me some peace of mind now, because I'd be screwed if I ever lost all that data due to file corruption...<br><br>Post edited by: Ace_NoOne, at: 2007/01/07 13:29
Ace_NoOne
Senior Boarder
Posts: 52
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1666
Re:all settings lost; missing "license.r2lic& 7 Years, 9 Months ago  
I guess I could do that. All the functionality is already there but at the moment you need to make the backups manually (Manager: File-&gt;Backup).
Rainy
Moderator
Posts: 5991
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#2321
Re:all settings lost; missing "license.r2lic& 7 Years, 8 Months ago  

Is this a common problem? Are there any other users who have experienced this?


Well... Common ? not quite ! But it does happen...
That's why I now have &quot;System scheduler&quot; running and saving the config once per hour
malbec
Junior Boarder
Posts: 23
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#2322
Re:all settings lost; missing "license.r2lic& 7 Years, 8 Months ago  

Is this a common problem? Are there any other users who have experienced this?


Well... Common ? not quite ! But it does happen...
That's why I now have &quot;System scheduler&quot; running and saving the config once per hour
malbec
Junior Boarder
Posts: 23
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#2323
Re:all settings lost; missing 7 Years, 8 Months ago  
malbec wrote:
That's why I now have &quot;System scheduler&quot; running and saving the config once per hour
That's why I said Rainlendar should do that automatically... <br><br>Post edited by: Ace_NoOne, at: 2007/02/16 12:43
Ace_NoOne
Senior Boarder
Posts: 52
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1234
get the latest posts directly to your desktop