Error 403 from Google Calendar? Upgrade to the new Google Calendar support. See here for details. close
Welcome, Guest
Please Login or Register.    Lost Password?

Can't install on kubuntu (Ubuntu 13.10+KDE 4.12.3)
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Can't install on kubuntu (Ubuntu 13.10+KDE 4.12.3)
#20881
Can't install on kubuntu (Ubuntu 13.10+KDE 4.12.3) 8 Months ago  
I got this problem:
root:/home/ssfirlogea/Downloads# dpkg -i rainlendar2-pro_2.12.2.b138-1_i386.deb
Selecting previously unselected package rainlendar2-pro.
(Reading database ... 279114 files and directories currently installed.)
Unpacking rainlendar2-pro (from rainlendar2-pro_2.12.2.b138-1_i386.deb) ...
dpkg: dependency problems prevent configuration of rainlendar2-pro:
rainlendar2-pro depends on libcurl3 (>= 7.16.0).
rainlendar2-pro depends on libatk1.0-0 (>= 1.20.0).
rainlendar2-pro depends on libcairo2 (>= 1.4.10).
rainlendar2-pro depends on libgtk2.0-0 (>= 2.12.0).
rainlendar2-pro depends on libpango1.0-0 (>= 1.16.2).
rainlendar2-pro depends on libxinerama1.
rainlendar2-pro depends on tofrodos.
rainlendar2-pro depends on libsdl1.2debian.
rainlendar2-pro depends on libjpeg62.
rainlendar2-pro depends on openssl (>= 1.0.1).
rainlendar2-pro depends on libwebkitgtk-1.0-0.

dpkg: error processing rainlendar2-pro (--install):
dependency problems - leaving unconfigured


But when I try to install the missing dependencies, I learn that they are already installed. Example:

root:/home/ssfirlogea/Downloads/rainlendar2# apt-get install libcurl3
Reading package lists... Done
Building dependency tree
Reading state information... Done
libcurl3 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.


Any ideea why?
sorin.sfirlogea
Fresh Boarder
Posts: 3
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#20886
Re:Can't install on kubuntu (Ubuntu 13.10+KDE 4.12.3) 8 Months ago  
Try this:
aptitude show libcurl3 libatk1.0-0 libcairo2 libgtk2.0-0 libpango1.0-0 libxinerama1 tofrodos libsdl1.2debian libjpeg62 openssl libwebkitgtk-1.0-0 | grep 'Paquete\|Versión\|Estado'
Paquete: libcurl3
Estado: instalado
Versión: 7.22.0-3ubuntu4.7
Paquete: libatk1.0-0
Estado: instalado
Versión: 2.4.0-0ubuntu1
Paquete: libcairo2
Estado: instalado
Versión: 1.10.2-6.1ubuntu3
Paquete: libgtk2.0-0
Estado: instalado
Versión: 2.24.10-0ubuntu6
Paquete: libpango1.0-0
Estado: instalado
Versión: 1.30.0-0ubuntu3.1
Paquete: libxinerama1
Estado: instalado
Versión: 2:1.1.1-3ubuntu0.1
Paquete: tofrodos
Estado: instalado
Versión: 1.7.9.debian.1-1
Paquete: libsdl1.2debian
Estado: instalado
Versión: 1.2.14-6.4ubuntu3
Paquete: libjpeg62
Estado: instalado
Versión: 6b1-2ubuntu1.1
Paquete: openssl
Estado: instalado
Versión: 1.0.1-4ubuntu5.11
Paquete: libwebkitgtk-1.0-0
Estado: instalado
Versión: 1.8.3-0ubuntu0.12.04.1
The grep part is locale dependent, so you must test without it and then edit according your own locale.
Then look for a version conflict and start to --force things up
Nilfred
Junior Boarder
Posts: 23
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: Argentina
The administrator has disabled public write access.
 
#20890
Re:Can't install on kubuntu (Ubuntu 13.10+KDE 4.12.3) 8 Months ago  
Thanks for the tip, Nilfred. Did that and the mistery goes deeper for me
Seems that all dependencies are met...

root:/home/ssfirlogea# aptitude show libcurl3 libatk1.0-0 libcairo2 libgtk2.0-0 libpango1.0-0 libxinerama1 tofrodos libsdl1.2debian libjpeg62 openssl libwebkitgtk-1.0-0 | grep 'Package\|Version\|State'
Package: libcurl3
State: installed
Version: 7.32.0-1ubuntu1.3
Package: libatk1.0-0
State: installed
Version: 2.10.0-2
Package: libcairo2
State: installed
Version: 1.12.16-0ubuntu2
Package: libgtk2.0-0
State: installed
Version: 2.24.20-1ubuntu1
Package: libpango1.0-0
State: installed
Version: 1.32.5-5ubuntu1
Package: libxinerama1
State: installed
Version: 2:1.1.3-1
Package: tofrodos
State: installed
Version: 1.7.9.debian.1-1build1
Package: libsdl1.2debian
State: installed
Version: 1.2.15-5ubuntu2
Package: libjpeg62
State: installed
Version: 6b1-3ubuntu1.13.10.1
Package: openssl
State: installed
Version: 1.0.1e-3ubuntu1.1
Package: libwebkitgtk-1.0-0
State: installed
Version: 1.10.2-0ubuntu3
sorin.sfirlogea
Fresh Boarder
Posts: 3
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#20891
Re:Can't install on kubuntu (Ubuntu 13.10+KDE 4.12.3) 8 Months ago  
If
uname -m
x86_64

Then try the 64 bit in "show all downloads"
BTW, I found a way not affected by locale:
Code:

dpkg-query -s libcurl3:i386 | grep 'Package\|Status\|Version'
Package: libcurl3
Status: install ok installed
Version: 7.22.0-3ubuntu4.7

Nilfred
Junior Boarder
Posts: 23
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: Argentina
The administrator has disabled public write access.
 
#20900
Re:Can't install on kubuntu (Ubuntu 13.10+KDE 4.12.3) 8 Months ago  
That was it. I needed the x64 version. Thanks a lot!
sorin.sfirlogea
Fresh Boarder
Posts: 3
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
get the latest posts directly to your desktop