Error 403 from Google Calendar? Upgrade to the new Google Calendar support. See here for details. close
Welcome, Guest
Please Login or Register.    Lost Password?

arch linux libpng problem at rainlendar startup
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: arch linux libpng problem at rainlendar startup
#12651
arch linux libpng problem at rainlendar startup 4 Years, 4 Months ago  
I have searched the forum to find a similar problem, but couldn't find it:

I'm using Arch Linux-64, kernel 2.6.34, libpng version 1.4.3-1.
And latest version of rainlendar: 2.7 build 91.

On starting rainlendar, the following error occurs:

rainlendar: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

So i tried creating a symlink: ln -s libpng14.so.14.3.0 libpng12.so.0

Then it displays this error:
rainlendar: /usr/lib/libcurl.so.4: no version information available (required by rainlendar)
rainlendar: /usr/lib/libpng12.so.0: version `PNG12_0' not found (required by rainlendar)

Before trying all sorts of things, including installing libpng12 alongside the newer version, I thought i'd try posting here first. Maybe there's an easier solution or a workaround?

Regards,
Chris
christopher72
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
Last Edit: 2010/07/13 06:43 By christopher72.
The administrator has disabled public write access.
 
#12738
Re:arch linux libpng problem at rainlendar startup 4 Years, 4 Months ago  
Anyone?
christopher72
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#12751
Re:arch linux libpng problem at rainlendar startup 4 Years, 4 Months ago  
quoting Rainy: "Seems that you have a incompatible version of the library that which Rainlendar depends on. You would have to install the libpng 1.2 onto your system. I don't have Arch Linux installation available so I don't know which exact version you need to install but in Ubuntu where the build was made the version number is 1.2.15~beta5-2ubuntu0.1 (32bit) and 1.2.15~beta5-3ubuntu0.1 (64bit) so probably anything from 1.2.15 to 1.2.44 should work.".

I installed 1.2.43 alongside the newer version, from here:
aur.archlinux.org/packages.php?ID=33795

The old and new version apparently don't conflict, so it's all fine.
There must be a reason why Ubuntu is using the old version though...
christopher72
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
get the latest posts directly to your desktop