Welcome, Guest
Please Login or Register.    Lost Password?

Recurrence problem (using day of the week)
(1 viewing) (1) Guest
Go to bottomPage: 12
TOPIC: Recurrence problem (using day of the week)
#15461
Recurrence problem (using day of the week) 3 Years, 2 Months ago  
i have a recurrence problem for new tasks.
i am running version 2.8.1 (b103), the free version.


if i add a new task with the following then the alarm pops up:

Start time: not checked
Due time: 6/22/2011 @ 9:00PM
Alarm: set to 0 min. before the task is due
Repeat every 1 month
Repeat on the 9th day of the month


if i add a new task with the following then the alarm DOES NOT pop up:

Start time: not checked
Due time: 6/22/2011 @ 9:00PM
Alarm: set to 0 min. before the task is due
Repeat every 1 month
Repeat on the second Thursday of the month

the difference is in using the numerical day of the month versus the
day of the week.

it should be noted that the same thing happens when i did a "New Event"
as well.
gwa999
Fresh Boarder
Posts: 14
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#15476
Re: Recurrence problem (using day of the week) 3 Years, 2 Months ago  
The 22nd of June is not the second Thursday of the month or 9th day of the month so you shouldn't even be able to create such tasks. Are you still able to reproduce this with the latest beta build?
Rainy
Moderator
Posts: 5956
graph
User Online Now Click here to see the profile of this user
The administrator has disabled public write access.
 
#15490
Re:Recurrence problem (using day of the week) 3 Years, 2 Months ago  
>> The 22nd of June is not the second Thursday of the month or 9th
>> day of the month so you shouldn't even be able to create such tasks.

and this is exactly why one should not change the options from what was the actual occurrence of the bug. :>) :>) originally i had a Due Time of: 6/9/2011 @ 9:00PM but changed it to 6/22/11 which was closer to the day that I actually posted the bug.

the original description was as follows:

if i add a new task with the following then the alarm pops up:

Start time: not checked
Due time: 6/9/2011 @ 9:00PM
Alarm: set to 0 min. before the task is due
Repeat every 1 month
Repeat on the 9th day of the month


if i add a new task with the following then the alarm DOES NOT pop up:

Start time: not checked
Due time: 6/9/2011 @ 9:00PM
Alarm: set to 0 min. before the task is due
Repeat every 1 month
Repeat on the second Thursday of the month


i will check to see if there is still an issue with the latest beta when i get a chance.
gwa999
Fresh Boarder
Posts: 14
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#15492
Re: Recurrence problem (using day of the week) 3 Years, 2 Months ago  
the latest beta (2.9, b107) seems to solve the problem.
gwa999
Fresh Boarder
Posts: 14
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#15493
Re: Recurrence problem (using day of the week) 3 Years, 2 Months ago  
i decided to do a recurrence test using the 24th (June) and "fourth Friday" using the 2.8.1 and beta version. the alarm did pop up for both. i'm pretty sure that i did really (?) have a problem when i set it for the 9th and second Thursday. i'm going to have to install Rainlendar into a virtual machine and play around with the date too see if there is some difference between setting up an alarm for the second Thursday vs. fourth Friday.
gwa999
Fresh Boarder
Posts: 14
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#15494
Re: Recurrence problem (using day of the week) 3 Years, 2 Months ago  
using the 2.9 (b107) beta i did a test using the 9th (June) and second Thursday and just like version 2.8.1 the alarm for the 9th popped up however the alarm for the second Thursday did NOT. i had reset the system date to the 9th for this test.

i then reset the system date to the 24th and the alarms for the 24th and fourth Friday both popped up.

apparently there is some difference when using "second Thursday" and "fourth Friday" as far as the logic which is causing one alarm to pop but not the other.
gwa999
Fresh Boarder
Posts: 14
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 12
get the latest posts directly to your desktop