Welcome, Guest
Please Login or Register.    Lost Password?

Weather doesn't work fine
(1 viewing) (1) Guest
Go to bottomPage: 1234567
TOPIC: Weather doesn't work fine
#17396
Re:Weather doesn't work fine 2 Years, 2 Months ago  
Thank you, I use the search option on the forum and I download the widgets from another post. Now everything works fine. Thank you.
RMRubert
Fresh Boarder
Posts: 8
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#17397
Re:Weather doesn't work fine 2 Years, 2 Months ago  
But in 119 the weather widget worked, in 120 it does not. Nothing else changed. Any ideas?
Mirage
Junior Boarder
Posts: 26
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#17398
Re:Weather doesn't work fine 2 Years, 2 Months ago  
anoob wrote:

I found a bug that the refresh time is always at 1970-01-01 00:00:00 +0000 (see image)


These are 3 examples of the XML files generated for "Buenos+Aires", "Hong+Kong" and "New+York": (www.google.com/ig/api?weather=[city])
Code:

<forecast_date data="2012-07-02"/><current_date_time data="1970-01-01 00:00:00 +0000"/>

<forecast_date data="2012-07-03"/><current_date_time data="2012-07-03 09:30:00 +0000"/>

<forecast_date data="2012-07-02"/><current_date_time data="2012-07-02 18:51:00 +0000"/>



Not sure if this is a Rainlenda bug.
Jorge_Luis
Platinum Boarder
Posts: 792
graphgraph
User Offline Click here to see the profile of this user
Gender: Male My Rainlendar Skins Location: Argentina Birthday: 03/15
The administrator has disabled public write access.
 
#17399
Re:Weather doesn't work fine 2 Years, 2 Months ago  
Thanks you Jorge Luis. It seems that the error is at google, not at Rainlendar.
Added, when i reopen it now, it show me 2012-07-03 11:00:00 +0000, but the current time of my city is 2012-07-03 08:00.
anoob
Platinum Boarder
Posts: 500
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: TaiChung, Taiwan, R.O.C. Birthday: 02/12
Last Edit: 2012/07/02 19:33 By anoob.
The administrator has disabled public write access.
I couldn't speak English! This skin released to Customize.org(Do you want it? Click Picture) Please contact me if interested: jhg5702@gmail.com
 
#17401
Re:Weather doesn't work fine 2 Years, 2 Months ago  
The "+0000" at the end means that the time is in UTC.
Rainy
Moderator
Posts: 5946
graph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#17415
Re:Weather doesn't work fine 2 Years, 1 Month ago  
I use the 64 Bit Version of Rainlendar2 with Windows 7 Ultimate 64 bit

With 64 bit Version Version Rainlendar-Lite-2.9-64bit.exe my weather widget based on StaticaColor-Weather skin worked perfectly

With 64 bit version Version Rainlendar-Lite-2.10-64bit.exe my weather widget based on StaticaColor-Weather skin fails to load the weather details and shows message Refreshing..... all the time.

I have checked the log file rainlendar2.log and the only difference I can find between Version 2.9 and 2.10 logs relating to the Weather Widget

BOTH Versions have the same line
Downloading: weather.msn.com/RSS.aspx?wealocations=wc:THXX0008&weadegreetype=C

BUT Version 2.10 has the following EXTRA Error line
11:20:27: [0:00:01.482] ERROR: Script download callback failed: [string "scripts/weather.lua"]:92: attempt to call field 'gfind' (a nil value)

I am guessing this relates to the problem, but not being a programmer or script writer I am unable to investigate further or resolve myself

I have installed/uninstalled Versions 2.9 and 2.10 several times and always upon reverting back to 2.9 the weather works and always fails with 2.10.

Installation with BOTH versions has been faultless with identical habits, options and "Do you want to install Rainlendar for All Users" Window, to which I respond "Yes"

I have regretfully had to revert to using the older Version 2.9 as a functioning the Weather Widget is important to me.

Hope this information helps
Regards
Muttley
Fresh Boarder
Posts: 15
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1234567
get the latest posts directly to your desktop