Welcome, Guest
Please Login or Register.    Lost Password?

Portable Static Build
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: Portable Static Build
#24551
Portable Static Build 1 Month, 3 Weeks ago  
To stave off dependency issues under Linux (I'm specifically thinking of Ubuntu/Debian), a portable static build of Rainlendar would be nice. The current stable version of Rainlendar requires libssl1.0.0, but Stretch currently has libssl1.0.2. I don't think both packages can coexist. Therefore I'm unable to use Rainlendar under Debian Stretch.
rainman
Fresh Boarder
Posts: 14
graphgraph
User Offline Click here to see the profile of this user
Last Edit: 2017/08/27 17:04 By rainman.
The administrator has disabled public write access.
 
#24554
Re: Portable Static Build 1 Month, 3 Weeks ago  
The latest beta version already links the ssl library statically.
Rainy
Moderator
Posts: 6860
graph
User Online Now Click here to see the profile of this user
The administrator has disabled public write access.
 
#24559
Re: Portable Static Build 1 Month, 3 Weeks ago  
That's nice, but there's still the issue of the libjpeg8 package.

Edit: And now libicu55 for the latest beta version.
rainman
Fresh Boarder
Posts: 14
graphgraph
User Offline Click here to see the profile of this user
Last Edit: 2017/08/30 00:58 By rainman.
The administrator has disabled public write access.
 
#24562
Re: Portable Static Build 1 Month, 3 Weeks ago  
The latest beta doesn't have direct dependencu to libjpeg8 anymore but it can come from some other dependency.

The libicu55 is probably not mandatory. I'll see if I can compile Rainlendar without it.
Rainy
Moderator
Posts: 6860
graph
User Online Now Click here to see the profile of this user
The administrator has disabled public write access.
 
#24621
Re: Portable Static Build 1 Month ago  
rainman
Fresh Boarder
Posts: 14
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 1
get the latest posts directly to your desktop