
Rainlendar 2.13 BETA build 139
Posted by Rainy - 2014/04/28 08:05
_____________________________________

Build 139 can be downloaded from here:



Windows (32-bit): Rainlendar-2.13.b139-32bit.zip

Windows (64-bit): Rainlendar-2.13.b139-64bit.zip

Linux TAR (32-bit): Rainlendar-2.13.b139-i386.tar.bz2

Linux DEB (32-bit): rainlendar2-pro_2.13.b139-1_i386.deb

Linux TAR (64-bit): Rainlendar-2.13.b139-amd64.tar.bz2

Linux DEB (64-bit): rainlendar2-pro_2.13.b139-1_amd64.deb

Mac OS X (Intel): Rainlendar-2.13.b139.dmg



MD5SUMS-b139



Translation file: rainlendar2.pot

Shadow4 skin addon: Shadow4-Widgets.r2skin-addon



This is beta version! It has not been tested.



Install instructions for Windows:

1. Make a backup (File->Backup in Rainlendar's manager dialog)

2. Download the zip file from above

3. Uncompress the contents of the zip over your current Rainlendar installation (C:\Program Files\Rainlendar2) 

4. Run Rainlendar2.exe



Changes:

o Fixes to the free day calendar layout.

o The manager could show current dates for recurring events before the actual start date.

o In advanced skin options it's now possible to move only the default windows to the active list.

o Changed the network and traytip delays to seconds in the settings.

o Failure to read events from Outlook did not always show an error message.

o Changed the way advanced options are handled so that translations won't affect incorrect setting.

o Added "None"-method for Google alarms which disables the default Google Calendar alarms.

o Dragging tasks under different sections in the to do list did not update the item.

o Added option to show the empty days in the event list.

o The default alarm for Outlook events did not dismiss unless the calendar was refreshed.

o It's not possible to use ';'-character in the calendar name since it is a separator when multiple calendars are used.

o The characters on event description were converted to utf-8 in Outlook events.

o Skin windows can be resized with the mouse.

o The EXDATE for events with time is stored as DATE-TIME instead just as DATE.

o Image scaling uses now nearest neighbour algorithm which doesn't give as good results but is much faster. Use
Options->Advanced->"Scaling quality" to change the quality.

o Fixed a crash bug in CalDAV when events were using time zones.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by bugreporter - 2014/04/28 10:27
_____________________________________

x64 version crashes on start, i simply cant get it to work: http://imgur.com/wxdevon

x86 version seem to work



Windows 8.1 with Update x64

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Rainy - 2014/04/28 11:54
_____________________________________

The 64 bit version had incorrect runtime libraries. I updated the build so let me know if it still refuses to run.

============================================================================
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Re:Rainlendar 2.13 BETA build 139
Posted by Schmidt - 2014/04/28 14:44
_____________________________________

x64 version crashes on start.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by anoob - 2014/04/28 15:55
_____________________________________

Not yet been fixed.



Recurrence problem while arranging task

http://www.rainlendar.net/cms/index.php?option=com_kunena&Itemid=42&func=view&catid=4&id=20557#20562



False trigger alarm? (The other issue I posted)

http://www.rainlendar.net/cms/index.php?option=com_kunena&Itemid=42&func=view&catid=4&id=20979&limit=6&limitsta
rt=6#21073

All setting:

set Options--Calendars--'Default alarm (minutes)' as "0"

Summary: test The last weekday event/task 

Start/End time: 2014/1/31(yyyy/m/d), All day event 

Alarm: 7 Days before the event starts. 

Recurrence: Repeat every 3 Months, On the last Friday of the month





Add:

Found new function Rainlendar_SetWindowSize(), but can not see it's introduction from Help -> API Reference

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Flamefire - 2014/04/28 16:38
_____________________________________

Formerly if you used the sidebar, the tasks and events parts were resized according to the number of tasks/events visible.

This has changed so e.g. it shows a fully blown up tasks schedule with no tasks in there. Instead the calender(month
view) is smaller.



I liked it better the way it was. Is this intended or could you change that?

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by ozzii - 2014/04/28 23:57
_____________________________________

Hi,

Here is the Serbian updated translation. http://www.rainlendar.net/cms/images/fbfiles/files/rainlendar2-
66f74d05a19f06946f93f5f4e9b08bc4.zip

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by bugreporter - 2014/04/29 00:53
_____________________________________

Rainy wrote:

The 64 bit version had incorrect runtime libraries. I updated the build so let me know if it still refuses to run.

Updated build works perfectly now.

Thank you so very much for such a quick fix!
Kunena - Rainlendar Kunena Forum Component version: NEW VERSION GOES HERE Generated: 28 June, 2017, 08:59



============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Rainy - 2014/04/29 10:49
_____________________________________

@anoob, I thought I fixed the first issue but I guess I didn't. I'll add it again to my backlog. The
Rainlendar_SetWindowSize() is in the index but the content is missing. Weird. I'll see what's wrong with it.



@Flamefire, the problem with the old sidebar was that it could grow outside the screen if there were a lot of entries. You
can now resize the window to fit in your screen. If you prefer to have small lists you can use the separate calendar, event
and to do windows. Or keep using the sidebar from the old version of the Shadow4 skin.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Flamefire - 2014/04/29 12:43
_____________________________________

So why can't you fix the problem that it could grow to much instead? It looks really strange...

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by evanade - 2014/04/29 20:08
_____________________________________

Traditional_Chinese has uploaded.

The localization file does not place on beta section. 

Lost strings: Day View, Moonphase, in skin select window, maybe can add in next build.

Thanks.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Jorge_Luis - 2014/04/30 08:46
_____________________________________

Spanish localization updated.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Loom - 2014/05/01 00:15
_____________________________________

German translation updated aswell.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Rainy - 2014/05/01 11:32
_____________________________________

The localization file does not place on beta section. 

Lost strings: Day View, Moonphase, in skin select window, maybe can add in next build.

The beta translations should go to separate list again.

"Day View" was removed by accident. "Moonphase" should be "Moon Phase". I'll fix those.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Kunena - Rainlendar Kunena Forum Component version: NEW VERSION GOES HERE Generated: 28 June, 2017, 08:59



Posted by ozzii - 2014/05/04 01:57
_____________________________________

When I launch the beta, from time to time, I have this error.

What can I do  to find how to repair this.



http://s25.postimg.org/v0jh3qt71/20140504_085252.png

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Rainy - 2014/05/04 02:17
_____________________________________

The assert is probably caused by an invalid time in one of the events (or alarms). It's usually nothing to worry about if
everything seems to be working fine. If you can find out what event is causing the problem I can try to check if it's a real
problem or just some side-effect in the date calculations.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by ozzii - 2014/05/04 03:37
_____________________________________

So nothing like a trace log (for example) for finding this error.

I have a lot of events, so finding the error will be tricky



While I'm here, where I need to post the beta translation.

I've posted here but it seems that it's not the right place :blush:

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Rainy - 2014/05/04 03:40
_____________________________________

Hmm... I wonder if it would be possible to show the full callstack in the asserts. That would make it easier to locate the
problem. I'll need to check that.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Rainy - 2014/05/04 03:47
_____________________________________

The beta translations can be uploaded to the language page like with the official version. They go to a separate section
at the bottom of the language's page so the files don't get mixed. I'll update the latest versions from the page when the
next version of Rainlendar is released.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Dasun - 2014/05/04 03:57
_____________________________________

It lools like there is a problem with the digital clock of the shadow4 skin. The clock didn't update itself the time. A refresh
of rainlendar is necessary to show the current time in the clock and then it stays at this time until the next refresh.



In 2.12.2, the clock did work.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Rainy - 2014/05/11 03:54
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_____________________________________

There's a bug related how the window gets updated. It might affect also the drawing order (items could be drawn below
others). I'll fix it in the next build.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Jorge_Luis - 2014/05/13 21:07
_____________________________________

There is a bug with this beta. The custom icon folder isn't read from the ini file. Refreshing does nothing. After selecting
the folder again in the Advanced tab works, but only for the current Rainlendar's session.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Rainy - 2014/05/16 10:33
_____________________________________

Ok, I'll check that out. It probably got broken when I refactored the settings.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Lou - 2014/05/26 17:25
_____________________________________

rainlendar2.log

00:21:40: Warning: iCCP: cHRM chunk does not match sRGB

00:21:40: Warning: iCCP: known incorrect sRGB profile

00:21:40:  ERROR: Number stack has 0 elements after evaluation. Should be 1.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Rainy - 2014/05/30 11:45
_____________________________________

The error suggests that there is some math formula in the skin which cannot be properly evaluated. You should check
those.

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Lou - 2014/05/31 11:43
_____________________________________

Rainy wrote:

The error suggests that there is some math formula in the skin which cannot be properly evaluated. You should check
those.

ERROR: Number stack has 0 elements after evaluation. Should be 1.

I found my error y="r" instead of y="0r" ;)



Warning: iCCP: cHRM chunk does not match sRGB

Warning: iCCP: known incorrect sRGB profile

Two warning appeared with build 139

default skin or not!

============================================================================

Re:Rainlendar 2.13 BETA build 139
Posted by Rainy - 2014/06/01 11:08
_____________________________________
Kunena - Rainlendar Kunena Forum Component version: NEW VERSION GOES HERE Generated: 28 June, 2017, 08:59



The warnings probably come from the png library. The could be caused by some image file which has incorrect color
information (or something...).

============================================================================
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